Treo 680 Surprise - Mic & Speaker Died

We had a bit of surprise here Friday evening as Mrs. Polarshark's Treo 680 went tango-uniform (tummy up). The speakerphone logo disappeared when she tried making a call and she could neither hear nor be heard. Well that makes the phone fairly unusable. But... everything else on the phone/PDA appeared to function normally. She's only had the refurbished phone for about seven months. She wasn't a happy camper.

I exercised the extent of my cellphone technical know-how by removing the battery and forcing a re-boot two or three times. (perhaps I could get a job in tech support?) I also walked through all of the possible settings looking for something that may have been accidentally 'set.' She has been known to get button-happy every now and then. No luck there either.

Saturday afternoon, as a last resort before heading off to the Cingular store (yes, I know they're AT&T now, but Cingular is stuck in my brain), I went online to check for potential solutions. Well, low and behold, I found this post on the dead microphone & speaker issue. It seems others (more than a few) have had the issue and it is caused by the phone thinking the headphone is still plugged in. The switch inside the phone may have gotten stuck. The phone is disabling the speaker and the microphone because it is convinced you are using the headset. Since the Mrs uses a wired headset (I'm strictly Bluetooth), it seemed like a reasonable possibility.

The solution given was to spray some WD-40 on the headphone plug and then insert it into the receptacle a couple of times. With gas prices being what they are, I decided that a little spray and poke might be worth a try. Presto, magico - it worked. This little solution saved us from having to buy her a new phone and the gas (mayhaps more than expensive than the phone itself).

Comments

And said…
Thanks- I was having the same problem and this did the trick! We didn't have WD40 around the lab, but we had a silicon lubricant and it worked fine.
Edwin said…
Gee, after 23 years in the army, I have never heard of Tango-Uniform being referred to as "Tummy-Up" LOL.

Nor "Toes-Up".

OK, I think they get my "drift" now :)